Tuesday, June 23, 2009

Script error fixed in 2.3.3456

There is a bug that appeared in Gallery Server Pro 2.3.3456 released last week. I just fixed it and updated the download packages to include it. I didn't rev the version number because that takes a few hours and this didn't seem important enough to justify the effort.

This affects those of you who disable the image metadata feature, as seen here on the Media Objects - General page in the Site admin area:

Screen shot showing the image metadata function disabled

If you kept this option enabled (which is the default), you are not affected by the issue.

When disabled, however, a javascript error occurs when you click the Next or Previous buttons as you browse an album. This is caused by a bug in the script file mediaobjectview.js. If this affects you, replace your version of this file with the latest one in one of the download packages (they all contain the same file). The file is located at \gs\script\mediaobjectview.js.

6 comments:

Wooer said...

Hello Roger, I have been implementing your great gallery server for about a year and just upgraded to the final version. I merged gsp web config to my web app's. and integrated it into my own masterpage. Uptonow nearly everything works perfect but I realized one thing. and it is when I double click on the album info to edit the pop up appears but save button does nothing... May you help? Since I don't know whether it is something I did or a bug..

Wooer said...

By the way one more thing.. I have translated the previous version that I was using into Turkish. and I am preparing to translate this one too... I can share the .resx file with you and with anyone who is interested after I'm done with the translation.

galleryserverpro said...

Sounds like AJAX might not be working, probably due to a misconfiguration in web.config. Do other AJAX functions work, like saving the caption on a photo and using the next/previous button to navigate within an album?

Dave Burke said...

Roger, Thank you for taking care of all of the details and for keeping us informed so well. I'll update that file, asap.

Wooer said...

Hello Roger again, first of all thanks a lot for your quick reply. And Yes other AJAX functions work very well... tested in Firefox the case is the same. the pop up shows up but save button not working. I can navigate between pics of an album, I can see them in slide, I can edit captions (But edit caption posts back, and then save captions button also posts back I think as they are supposed to do..) Only the save button neither saves nor closes the popup dialog... By the way my site is running under .net framework 3.5 and other parts of the site uses a lot of Ajax Functions properly.. And rounded corners are not seen in IE8 but visible in FF but this is not a primary problem...

Thanks a lot for your attention...

Roger Martin said...

I am not sure what is happening. Try to notice if there is a javascript error. Does the problem occur when you use the demo site?

Please use the forum for any follow-up posts. Thanks!